Quelle version d'Angular j'utilise ?

L’auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour,

J’ai décidé d’utiliser AngularJS dans mon nouveau projet (full stack) et histoire de m’aider à structurer mon projet j’ai choisis d’utiliser Yoeman. Avec le générateur le mieux noté actuellement : https://github.com/angular-fullstack/generator-angular-fullstack

Cependant je n’arrive pas à savoir si il m’a installé Angular 1 ou 4 ? Il n’a pas l’air de comprendre le ngFor, mais force l’utilisation du typeScript… Si vous pouviez m’aider à répondre à cette question ?

Charles

Édité par cbourree

Qui ne pète ni ne rote est voué à l’explosion.

+0 -0
Auteur du sujet

Merci

Erf c’est bien ce qu’il me semblait :'(

Mais pourquoi un générateur si bien noté et toujours autant téléchargé utilise une si vielle version d’Angular ?

Édité par cbourree

Qui ne pète ni ne rote est voué à l’explosion.

+0 -0

Peut être parce que, vu que les versions suivante d’Angular cassent tout, les gens ont pas envie ou le temps de ré-écrire entièrement leurs applications et continuent donc d’utiliser l’ancienne version tant qu’ils le peuvent ? C’est quelqu’un qui a fait passer, dans la douleur, deux boites à Python 3 qui témoigne : casser la compatibilité d’un projet très utilisé en entreprise fracture la communauté et cela prend du temps avant que tout le monde bascule. Du coup, en attendant, les anciennes versions restent utilisés et les outils dédiés continuent d’être utilisés.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte