Impossible d'enregistrer les modifications de propriétés de fichiers ...

J'ai beau faire enregistrer, ça ne sauvegarde pas la modification.

a marqué ce sujet comme résolu.
Auteur du sujet

Bonjour à tous,

J’ai un petit problème avec windows 10 : quand je vais modifier les propriétés d’un fichier a l’aide du clic-droit => propriétés => appliquer les changements, mes modifications ne sont pas enregistrées.

Hier j’ai voulu modifier certaines propriétés (titre, album, date etc.) de morceau mp3 pour qu’ils soient correctement reconnus par mon lecteur de musique. Je vais sur le morceau, j’ouvre les propriétés, je les modifie, j’applique les changements. Et si je ferme les propriétés et les re-ouvre, c’est comme si je n’avais rien fait.

Aujourd’hui j’ai voulu créer un nouveau dossier dans le répertoire C et décocher la case "lecture seule" pour permettre à un logiciel d’écrire dedans. Et rebelote : je décoche la lecture seule, j’enregistre, mais rien ne se passe. Si j’ouvre les propriétés le fichier est toujours en lecture seule comme si je n’avais rien changé. La propriété semble bien décochée.... http://prntscr.com/fou4nk Pourtant si je ferme et re-ouvre, elle est toujours là : http://prntscr.com/fou547

Une idée de pourquoi ce comportement et comment y remédier ?

“Your manuscript is both good and original. But the part that is good is not original, and the part that is original is not good.” Attributed to Samuel Johnson

+0 -0

Est-ce que c’est le cas avec tous les fichier mp3 ? Les propriétés d’un mp3 sont au format ID3, et il en existe plusieurs versions. Peut-être que Windows ne supporte pas les versions les plus récentes.


Par défaut quand l’on créer un dossier, il n’est pas en lecture seule, donc il n’y a rien à faire pour laisser un logiciel écrire dedans.

En fait, la checkbox "lecture seule" ne s’applique qu’aux fichiers, pas aux dossiers. Si tu coches/décoches cette case dans les propriétés d’un dossier, l’attribut "lecture seule" s’appliques aux fichiers qu’il contient.

En cas d’indétermination (seulement quelques fichiers en lecture seules), la checkbox du dossier affiche un carré noir. Cela ne signifie pas que le dossier est en lecture seule. Étrangement, la checkbox semble être souvent indéterminée.

+0 -0
Auteur du sujet

Est-ce que c’est le cas avec tous les fichier mp3 ? Les propriétés d’un mp3 sont au format ID3, et il en existe plusieurs versions. Peut-être que Windows ne supporte pas les versions les plus récentes.

Oui du moins tous ceux que j’ai testé.

Par défaut quand l’on créer un dossier, il n’est pas en lecture seule, donc il n’y a rien à faire pour laisser un logiciel écrire dedans.

Pourtant bizarrement si je créer un nouveau dossier vide dans C: il apparait en lecture seule. Et je voudrais utiliser un logiciel qui a besoin d’un répertoire pour stocker des trucs et a chaque fois il me dit qu’il ne peut pas écrire dans les répertoires que je lui indique, ce qui est cohérent avec la lecture seule…

“Your manuscript is both good and original. But the part that is good is not original, and the part that is original is not good.” Attributed to Samuel Johnson

+0 -0

Par défaut quand l’on créer un dossier, il n’est pas en lecture seule, donc il n’y a rien à faire pour laisser un logiciel écrire dedans.

Pourtant bizarrement si je créer un nouveau dossier vide dans C: il apparait en lecture seule. Et je voudrais utiliser un logiciel qui a besoin d’un répertoire pour stocker des trucs et a chaque fois il me dit qu’il ne peut pas écrire dans les répertoires que je lui indique, ce qui est cohérent avec la lecture seule…

Demandred

Le carré noir ne signifie pas que le dossier est en lecture seul. Je pense que c’est plutôt un problème de permission. Clique droit sur le dossier > propriétés > sécurité pour voir/modifier les permissions d’un dossier.

+0 -0
Auteur du sujet

Le carré noir ne signifie pas que le dossier est en lecture seul.

Ha ? Il signifie quoi du coup ?

Clique droit sur le dossier > propriétés > sécurité pour voir/modifier les permissions d’un dossier.

En effet j’ai bien les permissions de ce coté là… J’ai réussit à résoudre mon problème concernant mon logiciel, je vais tester de voir pour les mp3 si ça fonctionne ou pas.

Merci pour ton aide. ;)

“Your manuscript is both good and original. But the part that is good is not original, and the part that is original is not good.” Attributed to Samuel Johnson

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte