[BUG] tutoriel API REST avec Symfony 3

Code non fonctionnel

a marqué ce sujet comme résolu.
Auteur du sujet

Bonjour ! Dans le tutoriel Créez une API REST avec Symfony 3, il me semble qu’il y ai une erreur de code dans le section : Créez une API REST avec Symfony 3 Développement de l’API REST > Premières interactions avec les ressources

Ce code ne fonctionne pas chez moi

1
2
3
4
5
6
7
8
 public function getPlacesAction(Request $request)
    {
        return new JsonResponse([
            new Place("Tour Eiffel", "5 Avenue Anatole France, 75007 Paris"),
            new Place("Mont-Saint-Michel", "50170 Le Mont-Saint-Michel"),
            new Place("Château de Versailles", "Place d'Armes, 78000 Versailles"),
        ]);
    }

Mais ce code semble etre correct :

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
public function getPlacesAction(Request $request)
    {
        $places = [
            new Place("Tour Eiffel", "5 Avenue Anatole France, 75007 Paris"),
            new Place("Mont-Saint-Michel", "50170 Le Mont-Saint-Michel"),
            new Place("Château de Versailles", "Place d'Armes, 78000 Versailles"),
        ]

        $formatted = [];
        foreach ($places as $place) {
            $formatted[] = [
               'id' => $place->getId(),
               'name' => $place->getName(),
               'address' => $place->getAddress(),
            ];
        }

        return new JsonResponse($formatted);
    }

Voilà !

Édité par AlexisMrc

+0 -0

Bonjour,

Ce forum concerne les bugs et suggestions liés au site (d’un point de vue technique) et non les contenus. Je t’invite à poster ton message dans les commentaires dur tutoriel en question. :)

"I think that it’s extraordinarily important that we in computer science keep fun in computing." — Alan J. Perlis

+0 -0
Ce sujet est verrouillé.