Impossible de booter sur ElementaryOS

Seul Windows se lance ...

L’auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Reprise du dernier message de la page précédente

Ah d'accord, ben non j'ai même pas ça.

Je vais essayer de booter sur un autre PC à l'occasion, voir si ça marche, où si c'est le mien qui est mal foutu (à moins que j'ai mal mis en place gummiboot, mais j'ai bien suivit le tuto, ça devrait marcher).

+0 -0

Tu n'as pas de fast-boot d'activé non plus ? (sinon le lien ne pointe sur rien)

Si je suis arrivé à me faire comprendre dans ce bout de paragraphe, normalement tu as sur ta clé:

  • EFI/Boot/bootx64.efi : le binaire gummiboot
  • loader/loader.conf : le fichier de conf' racine
  • loader/entries/rim.conf : une entrée de menu

(j'embraye sur les questions stupides)

Sinon, ta clé, elle a bien une partition FAT32 avec le drapeau boot ?

Autre question : dans la conf' de l'UEFI (accessible comme la conf' d'un BIOS : Esc ou F2 ou truc similaire lors de l'allumage de la bécane), t'as bien mis les périphériques type clé USB avant le disque dur dans l'ordre de boot ?

Édité par dosmpm

There is no place like /home.

+0 -0
Auteur du sujet

Tu n'as pas de fast-boot d'activé non plus ? (sinon le lien ne pointe sur rien)

J'ai pas d'option qui s'appelle comme ça, donc je ne penses pas.

Si je suis arrivé à me faire comprendre dans ce bout de paragraphe, normalement tu as sur ta clé:

  • EFI/Boot/bootx64.efi : le binaire gummiboot
  • loader/loader.conf : le fichier de conf' racine
  • loader/entries/rim.conf : une entrée de menu

J'ai exactement ça, oui.

Sinon, ta clé, elle a bien une partition FAT32 avec le drapeau boot ?

Je l'ai pas partitionnée, mais elle doit avoir une partition par défaut non (sinon c'est bien une FAT32)

Autre question : dans la conf' de l'UEFI (accessible comme la conf' d'un BIOS : Esc ou F2 ou truc similaire lors de l'allumage de la bécane), t'as bien mis les périphériques type clé USB avant le disque dur dans l'ordre de boot ?

dosmpm

En fait je ne peut pas changer l'ordre de boot. J'ai juste une menu où on me demande sur quel périphérique je veux booter et je sélectionne alors ma clé USB.

+0 -0

Je l'ai pas partitionnée, mais elle doit avoir une partition par défaut non (sinon c'est bien une FAT32)

J'insiste, c'est important : elle a bien le drapeau boot cette partition ?

Il peut très bien te donner le choix de la clé parce qu'elle est branchée mais, ne trouvant pas de FAT32 avec le drapeau boot, il passe au disque dur et donc à windows.

L'UEFI ne cherche que les FAT32 avec le drapeau boot quand il cherche son esp.

There is no place like /home.

+0 -0

Cette réponse a aidé l’auteur du sujet

Je te renvoies à ceci. Si tu n'y arrive pas j'ai une solution avec diskpart, mais comme je n'ai jamais utilisé l'outil je préfère utiliser les outils windows edulcorés.

Tu vois les drapeaux que possèdent une partition quand tu utilise un logiciel de partitionnement, gparted par exemple. Le drapeau boot est là pour dire que c'est la partition qui doit être utilisée pour le boot (ce qui semble relativement logique).

Bonne soirée !

There is no place like /home.

+0 -0
Auteur du sujet

Bon, je déterre un peu, mais c'est pour les personnes qui rencontrerai le même problème que moi, puisque j'ai trouvé ce qui n'allait pas.

C'est tout simplement que mon PC est en 32bits et son UEFI aussi. Or, la plupart des distributions Linux ne le supporte pas, et il est donc impossible de booter dessus (même si je crois que ça va bientôt être le cas dans ElementaryOS).

Voilà, donc la seule solution est en fait d'attendre que l'UEFI 32bits soit supporté par une distribution.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte