Probleme d'encodage et de recherche

Le problème exposé dans ce sujet a été résolu.

Bonsoir chers amis je développe mon site et j’ai un problème d’encodage j’ai chercher des solutions et je n’ai rien trouver je demande votre aide.

J’ai créer ma table en utilisant l’encodage utf8_general_ci les accents s’affichent très bien dans ma base de données tandis qu’elles s’ affichent mal dans mon site web, et lorsque je fais des requêtes contenant des caractères accentués il ne retourne pas le résultat malgré que celui ci existe et quand j’enlève les accents ça fonctionne sans problème.

Je précise que j’ai mis la balise méta char set utf-8 dans mes pages HTML.

Merci pour tous vos réponses.

+0 -0

Le problème peut venir de beaucoup de choses. Tu sembles utilisé PHP, la page HTML est-elle bien enregistrer en UTF-8 ? Je veux dire le fichier lui-même pas la balise meta.

On va avoir besoin de plus d’informations. Comme par exemple, quel est concrètement le rendu qui pose problème ?

Sur la page d’accueil il y a un tutoriel actuellement en Une Comprendre les encodages. En fonction du rendu on peut mieux comprendre le problème.

Bref, comme toujours melo96, donne nous le maximum d’information pour t’aider.

+0 -0

Bon ben on a la solution.

Je te conseil d’aller lire le tutoriel sur l’encodage. Ici, c’est du latin1 interprété comme de l’UTF-8 (ça se voit, lit le tutoriel tu comprendras).

Ça signifie que le mot « liké » que tu as en base de donné est encodé en latin1 (ou que tu le récupères du manière à changer l’encodage mais j’en doute). Du coup, ne cherche pas au niveau de ta page, c’est au niveau de la base de données. Vérifie que MySQL est configuré pour utiliser UTF-8 et que tu lorsque tu as entré les données, tu les as entré en UTF8.

+0 -0

coucou les amis j’ai un comportement que je ne comprends pas bien.

$bdd = new PDO('mysql:host=localhost;dbname=nom_base;charset=utf8', 'root', '');

Sur ma page forum lorsque j’enlève charset=utf8 les caractères accentues s’affichent sans problème.

Comment vous m’expliquez ça?

Tandis dans ma page astuce je suis obliger de mettre ça pour pouvoir voir les caractères accentués?

bizarre ça

Merci pour vos différentes réponses.

+0 -0
Connectez-vous pour pouvoir poster un message.
Connexion

Pas encore membre ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte