Problème d'installation du backend de zds

bash: virtualenv : commande introuvable

L’auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Si quelqu’un d’autre lit, c’est : python manage.py runserver 0.0.0.0:8000 avec deux points.

Il n’y a aucune option pour activer une authentification HTTP ? Ou une autre astuce pour rendre moins accessible la beta qui est sur mon VPS avec un debug true ? J’imagine que je dois utiliser apache comme pare-feu ?

✈️ // 🐺 Ami des loups // 🎮 Coding Game // 🐤 Twitter @A312_zds // :B // L’hiver vient // @**A-312** pour me ping

+0 -0
Auteur du sujet

Tu as juste à ne pas ouvrir tes ports, ça doit pouvoir se gérer depuis l’administration de ton VPS, sinon tu peux utiliser un firewall.

tleb

Je souhaite pouvoir y accéder via mon propre navigateur. Je sais qu’il y a le X11 mais j’ai peur que si je fais du front ça déforme le vrai rendu à cause de la latence d’affichage.

✈️ // 🐺 Ami des loups // 🎮 Coding Game // 🐤 Twitter @A312_zds // :B // L’hiver vient // @**A-312** pour me ping

+0 -0
Auteur du sujet

Je ne sais pas c’est une beta. Je pense que ce n’est pas trop compliqué. Je vais le faire, au moins c’est fait. Le script letsencrypt est devenu certbot ?

Je suppose que oui : https://github.com/letsencrypt/letsencrypt


Ensuite dois-je mettre à jour le kernel de mon vps ovh ? "Linux vps312 2.6.32–042stab127.2" c’est une opération risquée ?

✈️ // 🐺 Ami des loups // 🎮 Coding Game // 🐤 Twitter @A312_zds // :B // L’hiver vient // @**A-312** pour me ping

+0 -0
Auteur du sujet
(zdsenv) a312:~/zds/zds-site$ make install-back
pip3 install --upgrade -r requirements-dev.txt
Double requirement given: Pygments==2.2.0 (from -r requirements.txt (line 25)) (already in pygments==2.2.0 (from -r requirements.txt (line 2)), name='Pygments')
Storing debug log for failure in /home/a312/.pip/pip.log
Makefile:48: recipe for target 'install-back' failed
make: *** [install-back] Error 1

Logs:

------------------------------------------------------------
/home/a312/zds/zds-site/zdsenv/bin/pip3 run on Tue Aug 28 15:36:22 2018
Double requirement given: Pygments==2.2.0 (from -r requirements.txt (line 25)) (already in pygments==2.2.0 (from -r requirements.txt (line 2)), name='Pygments')
Exception information:
Traceback (most recent call last):
  File "/home/a312/zds/zds-site/zdsenv/lib/python3.4/site-packages/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/home/a312/zds/zds-site/zdsenv/lib/python3.4/site-packages/pip/commands/install.py", line 275, in run
    requirement_set.add_requirement(req)
  File "/home/a312/zds/zds-site/zdsenv/lib/python3.4/site-packages/pip/req.py", line 989, in add_requirement
    % (install_req, self.get_requirement(name), name))
pip.exceptions.InstallationError: Double requirement given: Pygments==2.2.0 (from -r requirements.txt (line 25)) (already in pygments==2.2.0 (from -r requirements.txt (line 2)), name='Pygments')

Édité par A-312

✈️ // 🐺 Ami des loups // 🎮 Coding Game // 🐤 Twitter @A312_zds // :B // L’hiver vient // @**A-312** pour me ping

+0 -1

Cette réponse a aidé l’auteur du sujet

Salut.

Qu’est-ce que ça donne en supprimant la ligne 25 de requirements.txt ?

"Les accidents dans un système doivent se produire, mais il n’est pas obligatoire qu’ils produisent pour vous et moi." Laurence Gonzales - Deep Survival

+0 -0
Auteur du sujet

Je ne sais pas trop pourquoi mais j’ai commenté la première ligne pour ne pas avoir l’erreur au deuxième appelle de Pygments==2.2.0.

Apparemment aucune réaction en chaine. :euh: Je fais toujours planter un truc quand je fais une modif en aveugle.


@rezemika Ah , tu as posté avant moi.

✈️ // 🐺 Ami des loups // 🎮 Coding Game // 🐤 Twitter @A312_zds // :B // L’hiver vient // @**A-312** pour me ping

+0 -0
Auteur du sujet

Pourquoi j’ai eu cette erreur maintenant ?

Il y a une semaine avant de réinstaller Linux, j’avais fais l’installation et je n’ai eu aucun soucis. Pourquoi ça pose problème aujourd’hui ? Le dernier changement dans le fichier a eu lieu il y a 4 mois.

Édité par A-312

✈️ // 🐺 Ami des loups // 🎮 Coding Game // 🐤 Twitter @A312_zds // :B // L’hiver vient // @**A-312** pour me ping

+0 -0
Auteur du sujet

Je suis encore là avec un sushi X/

Quand la connexion SSH (via PuTTY) se ferme avec la commande python manage.py runserver en cours, le serveur continue à tourner comment j’arrête la commande ? Autre que kill

Édité par A-312

✈️ // 🐺 Ami des loups // 🎮 Coding Game // 🐤 Twitter @A312_zds // :B // L’hiver vient // @**A-312** pour me ping

+0 -0

Hum, ça ne résoud pas vraiment le problème, mais tu peux lancer la commande dans un screen. Comme ça, à ta prochaine connexion sur le serveur, tu aura juste à rentrer dans le screen pour arrêter le serveur.

"Les accidents dans un système doivent se produire, mais il n’est pas obligatoire qu’ils produisent pour vous et moi." Laurence Gonzales - Deep Survival

+1 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte